Page 1 of 1

Error Starting Recording with Neurorecorder

Posted: Thu Oct 19, 2023 11:09 am
by Kevan Hashemi
A customer writes, "I discovered today that the wireless eeg recording had stopped sometime yesterday and neurorecorder was giving this error message "Error: Timeout reading 9 bytes from sock0000000004527870" and each time I tried to restart the recording or start a new recording this code showed up. I am unsure what the is issue is and was hoping you would have some insight so we can get the recoding started again?"

Re: Error Starting Recording with Neurorecorder

Posted: Thu Oct 19, 2023 11:36 am
by Kevan Hashemi
Dear Customer,

Please correct me if I am wrong, but I believe you are using a LWDAQ Driver (black box, A2071E) with Octal Data Receiver (silver box, A3027E). If so, the timeout error means that the Neurorecorder was able to connect to your driver, but has been unable to download data from the your receiver.

Please let me know your version of the LWDAQ Software. You will find the version in the About LWDAQ panel, which you can open in the LWDAQ menu. We have been working on the handling of errors by the Neurorecorder Tool and Receiver Instrument in the past few updates to the code, and I'd like to know which one you are using.

One way you can get this timeout error is by entering the incorrect value for driver_sckt in the Neurorecorder. There are eight sockets on the front face of the driver. Number one is closest to the indicator lamps. We have our receiver connected to one of these sockets with a shielded network cable. We need driver_sckt set to the number of this socket. You must have had driver_sckt set correctly, or else your recording would never have worked. But it is possible that the cable has been unplugged or damaged. Please check the cables.

Another possibility is that your computer has updated itself and decided that the LWDAQ messaging protocol should not be allowed through your local firewall. Is your computer connected to your local wireless network? If so, it may have performed an update and changed its firewall settings. In order to check that you are connected to the LWDAQ Driver, please try contacting it with the Configurator Tool, manual at link below. I assume your driver's IP address is (the default), but you may have changed the address.

Assuming you can contact the driver, open the Neurorecorder and press Receiver to get a Receiver Instrument panel. Enter the IP address for your driver and the driver_sckt of your receiver. Press "Reset and Configure". Is the Receiver Instrument able to identify the version of your data receiver?

If so, press Loop to see if the Receiver Instrument can download data from our receiver. Watch for a minute. Do you get any errors or warning?

If not, stop the Receiver Instrument but leave its window open so you can view live data during recording. Return to the Neurorecorder. Try once more to start a recording. Watch for a minute. Do you get a timeout error? If so, what warnings and errors are visible in the Recorder Instrument?

Another problem that can stop your recording is your hard disk getting full. But I believe, in the latest version of LWDAQ, that the error message for a full hard drive is distinct from the message we get when we cannot download the data from the receiver.

Best Wishes, Kevan

Re: Error Starting Recording with Neurorecorder

Posted: Thu Oct 19, 2023 3:54 pm
by gofortha

We are using LWDAQ version 10.5.5. I did use the configurator tool to try and make contact with the driver and originally got the same timeout error code but I was able to reset the LWDAQ's EEPROM using the instructions in the manual you linked and everything else ran smoothly from there with checking the receiver and starting up the recording again!


Re: Error Starting Recording with Neurorecorder

Posted: Thu Oct 19, 2023 4:36 pm
by Kevan Hashemi
Dear Gofortha,

Thank you for your report. I am glad the communication is working again. What is the IP address now?

If the IP address is now set to some value other than the default, then perhaps the configuration switch on the driver was pressed by some nearby object when the driver recovered from a short power cut. That's possible.

But I suspect you are using the default address. If so, I see no way that the IP address could have been set to some other value by accident. Nor do I think it likely that someone connected to the driver and changed its IP address with the Configurator. So I think this problem is likely to occur again, because we have not yet identified the cause.

When it happens again, please press the reset button on the front of the LWDAQ Driver and see if communication can start up again. If the reset works, then I have a theory about what is going on. If my theory is correct, I claim we can fix your problem by updating the LWDAQ Driver's firmware to set tcp_timeout to 10 (ten-second timeout for broken connections). So, please let me know when the problem happens again.

Best Wishes, Kevan

Re: Error Starting Recording with Neurorecorder

Posted: Thu Oct 19, 2023 5:01 pm
by gofortha
Yes, the IP address we were using is and it was the same before and after resetting the LWDAQ EEPROM. I will see if the problem occurs again and will try pressing the reset button to see if that restores the communication then let you know!

Thank you